1,233
Downloads
6.9MB
Size
5da0a07507cff0cd3a95bda5ccd01274
MD5
Jul 29, 2019 | 05:31AM
Upload Date
Description:
changelog:
mm: build fix
slab: fix wrongly used macro
slab: Fix off by one in object max number tests.
slab: fix the type of the index on freelist index accessor
mm: slab/slub: use page->list consistently instead of page->lru
mm, mempolicy: remove per-process flag
mm, mempolicy: rename slab_node for clarity
mm: optimize put_mems_allowed() usage
mm/hugetlb.c: use memblock apis for early memory allocations
mm/hugetlb.c: defer PageHeadHuge() symbol export
mm/hugetlb.c: simplify PageHeadHuge() and PageHuge()
mm: hugetlb: use get_page_foll() in follow_hugetlb_page()
mm: thp: give transparent hugepage code a separate copy_page
mm: hugetlb: initialize PG_reserved for tail pages of gigantic compound pages
mm/hugetlb.c: correct missing private flag clearing
mm, hugetlb: grab a page_table_lock after page_cache_release
mm: prepare to remove /proc/sys/vm/hugepages_treat_as_movable
mm: memory-hotplug: enable memory hotplug to handle hugepage
mm: mbind: add hugepage migration code to mbind()
mm: migrate: make core migration code aware of hugepage
mm, hugetlb: return a reserved page to a reserved pool if failed
mm, hugetlb: remove useless check about mapping type
mm, hugetlb: fix subpool accounting handling
mm, hugetlb: change variable name reservations to resv
mm, hugetlb: protect reserved pages when soft offlining a hugepage
mm, hugetlb: decrement reserve count if VM_NORESERVE alloc page cache
mm, hugetlb: remove decrement_hugepage_resv_vma()
mm, hugetlb: add VM_NORESERVE check in vma_has_reserves()
mm, hugetlb: do not use a page in page cache for cow optimization
mm, hugetlb: remove redundant list_empty check in gather_surplus_pages()
mm, hugetlb: fix and clean-up node iteration code to alloc or free
mm, hugetlb: clean-up alloc_huge_page()
mm, hugetlb: trivial commenting fix
mm, hugetlb: move up the code which check availability of free huge page
mm/hugetlb: use already existing interface huge_page_shift
mm/slab.c: cleanup outdated comments and unify variables naming
slab: Make allocations with GFP_ZERO slightly more efficient
slab: make more slab management structure off the slab
slab: introduce byte sized index for the freelist of a slab
slab: restrict the number of objects in a slab
slob: Rework #ifdeffery in slab.h
slab: introduce helper functions to get/set free object
slab: factor out calculate nr objects in cache_estimate
mm: Fix warning on make htmldocs caused by slab.c
memcg, kmem: rename cache_from_memcg to cache_from_memcg_idx
slab: replace non-existing 'struct freelist *' with 'void *'
slab: fix to calm down kmemleak warning
slab: rename slab_bufctl to slab_freelist
slab: remove useless statement for checking pfmemalloc
slab: use struct page for slab management
slab: replace free and inuse in struct slab with newly introduced active
slab: remove SLAB_LIMIT
slab: remove kmem_bufctl_t
slab: change the management method of free objects of the slab
slab: use __GFP_COMP flag for allocating slab pages
slab: use well-defined macro, virt_to_slab()
slab: overloading the RCU head over the LRU for RCU free
slab: remove cachep in struct slab_rcu
slab: remove nodeid in struct slab
slab: remove colouroff in struct slab
slab: change return type of kmem_getpages() to struct page
slab: correct pfmemalloc check
mm/slab: Give s_next and s_stop slab-specific names
mm/slab: Sharing s_next and s_stop between slab and slub
mm/slab: Fix drain freelist excessively …
mm, slab: moved kmem_cache_alloc_node comment to correct place
Additional Information: